Desert Cove Elementary School power outage

Resolved

This incident has been resolved.
Posted Aug 11, 2026 - 15:27 MST

Monitoring

Power has been restored. HVACs powering up. We will continue to monitor.
Posted Aug 11, 2026 - 10:03 MST

Investigating

Desert Cove is experiencing a power outage. While phones and internet are up, HVAC is down. Facilities is investigating cause. We will keep you updated.
Posted Aug 11, 2026 - 07:45 MST
This incident affected: District Sites (Desert Cove).