Clever – New Users Unable to Access Curriculum Applications

Resolved

This incident has been resolved.
Posted Jun 22, 2026 - 07:44 MST

Update

Clever is continuing to investigate this issue.
Posted Jun 18, 2026 - 10:28 MST

Investigating

Clever is currently investigating this issue.
Posted Jun 16, 2026 - 12:30 MST
This incident affected: District Sites (Entire District) and Systems (Clever).