Infinite Campus Is Currently Down

Resolved

This incident has been resolved.
Posted Dec 01, 2025 - 10:22 MST

Update

Issue appears to be impacting a number of school districts. Vendor is working on diagnosing the issue.
Posted Dec 01, 2025 - 09:36 MST

Investigating

IT is working with Infinite Campus on this issue.
Posted Dec 01, 2025 - 09:27 MST
This incident affected: Systems (Infinite Campus).