Infinite Campus is back up!

Resolved

This incident has been resolved.
Posted Aug 11, 2026 - 15:27 MST

Update

We are continuing to monitor for any further issues.
Posted Aug 11, 2026 - 07:50 MST

Update

We are continuing to monitor for any further issues.
Posted Aug 11, 2026 - 07:50 MST

Monitoring

Infinite Campus is back up. We will continue to monitor. Thank you for your patience this morning!
Posted Aug 11, 2026 - 07:49 MST

Update

Infinite Campus is reporting that other districts reporting same issue. They are investigating.
Posted Aug 11, 2026 - 07:47 MST

Investigating

Infinite Campus has been notified and they are looking into it. We will keep you updated.
Posted Aug 11, 2026 - 07:16 MST
This incident affected: Systems (Infinite Campus) and District Sites (Entire District).