JPL/SCES Power issue

Resolved

This incident has been resolved.
Posted Aug 06, 2026 - 10:09 MST

Monitoring

Power has been restored. We will monitor.
Posted Aug 06, 2026 - 09:31 MST

Identified

Facilities is responding to power issue at site. We will keep you posted.
Posted Aug 06, 2026 - 09:09 MST
This incident affected: District Sites (Sunset Canyon).