Study Sync is Experiencing a Service Outage
Resolved
This incident has been resolved.
Posted Mar 08, 2024 - 09:05 MST
Investigating
Study Sync is currently investigating an issue impacting user login and access.
Their teams are actively working to resolve this as quickly as possible. They apologize for any inconvenience and appreciate your patience..
Posted Mar 08, 2024 - 07:52 MST
This incident affected: Systems (McGraw-Hill).