AT&T Experiencing Widespread Outage - Not Observable in PV
Resolved
This incident has been resolved.
Posted Feb 25, 2024 - 17:54 MST
Monitoring
AT&T has been experiencing a widespread outage incident since 1 AM Arizona time. This outage is impacting some AT&T customers ability to make calls, send texts, or use the cellular data network.

The AT&T outage does not appear to be impacting the district's network or online services.
Posted Feb 22, 2024 - 08:38 MST
This incident affected: District Sites (Entire District).