McGraw Hill Service Interruption for Assessments
Resolved
This incident has been resolved.
Posted Apr 11, 2024 - 14:14 MST
Investigating
McGraw Hill is currently experiencing an issue that might be affecting your access to assignments.
Their teams are actively investigating this matter with the highest priority to identify and resolve the issue promptly..
Posted Apr 11, 2024 - 10:19 MST
This incident affected: Systems (McGraw-Hill).